Problem with the initial configuration in production enviroment

Hello everyone, I am new in this and I am interesting in having an installation of this software. First of all I am trying to make I local instalation. I am following these steps fab-manager/ at master · sleede/fab-manager · GitHub

During the installation everything semes to be ok, but try to access to my local instalation I get this erro message:

We're sorry, but something went wrong.
If you are the application owner check the logs for more information.

In app-stdout.log I get this message:

Completed 500 Internal Server Error in 18ms (ActiveRecord: 4.4ms | Elasticsearch: 0.0ms)
ActionView::Template::Error (Webpacker can't find application.css in /usr/src/app/public/packs/manifest.json. Possible causes:
1. You want to set webpacker.yml value of compile to true for your environment
   unless you are using the `webpack -w` or the webpack-dev-server.
2. webpack has not yet re-run to reflect updates.
3. You have misconfigured Webpacker's config/webpacker.yml file.
4. Your webpack configuration is not creating a manifest.
Your manifest contains:
    54:       Fablab.sessionTours = [];
    55:   </script>
    57:   <%= stylesheet_packs_with_chunks_tag 'application', media: 'all' %>
    58:   <%= stylesheet_packs_with_chunks_tag 'plugins', media: 'all' %>
    59:   <%= stylesheet_packs_with_chunks_tag 'printer', media: 'print' %>
    60:   <% unless Stylesheet.theme.nil? %>

I can’t find any manifest.json or webpacker.yml. How can I solve that problem?

There may be an error with the assets compilcation.
You can try to build them again, running the following:

docker-compose run --rm fabmanager bundle exec rails assets:precompile

Hello, thank you for your response. Now I am trying to install the software in another server. In this server I get a problem too. When I run this command I get:

/usr/local/bundle/gems/ffi-1.12.2/lib/ffi/library.rb:112: [BUG] Illegal instruction at 0x00007f4a184bf904
ruby 2.6.6p146 (2020-03-31 revision 67876) [x86_64-linux-musl]

-- Control frame information -----------------------------------------------
c:0065 p:---- s:0363 e:000362 CFUNC  :open
c:0064 p:0022 s:0357 e:000356 BLOCK  /usr/local/bundle/gems/ffi-1.12.2/lib/ffi/library.rb:112 [FINISH]
c:0063 p:---- s:0348 e:000347 CFUNC  :each
c:0062 p:0113 s:0344 e:000343 BLOCK  /usr/local/bundle/gems/ffi-1.12.2/lib/ffi/library.rb:109 [FINISH]
c:0061 p:---- s:0337 e:000336 CFUNC  :map
c:0060 p:0069 s:0333 e:000332 METHOD /usr/local/bundle/gems/ffi-1.12.2/lib/ffi/library.rb:99
c:0059 p:0079 s:0326 e:000325 CLASS  /usr/local/bundle/gems/sassc-2.2.1/lib/sassc/native.rb:11
c:0058 p:0007 s:0322 e:000321 CLASS  /usr/local/bundle/gems/sassc-2.2.1/lib/sassc/native.rb:6
c:0057 p:0014 s:0319 e:000318 TOP    /usr/local/bundle/gems/sassc-2.2.1/lib/sassc/native.rb:5 [FINISH]
c:0056 p:---- s:0316 e:000315 CFUNC  :require
c:0055 p:0013 s:0311 e:000310 BLOCK  /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23
c:0054 p:0074 s:0308 e:000307 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92
c:0053 p:0023 s:0296 e:000295 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22
c:0052 p:0052 s:0290 e:000289 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31
c:0051 p:0008 s:0283 e:000282 BLOCK  /usr/local/bundle/gems/activesupport-
c:0050 p:0068 s:0280 e:000279 METHOD /usr/local/bundle/gems/activesupport-
c:0049 p:0011 s:0273 e:000272 METHOD /usr/local/bundle/gems/activesupport-
c:0048 p:0037 s:0267 e:000266 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:49
c:0047 p:0021 s:0261 e:000260 TOP    /usr/local/bundle/gems/sassc-2.2.1/lib/sassc.rb:31 [FINISH]
c:0046 p:---- s:0258 e:000257 CFUNC  :require
c:0045 p:0013 s:0253 e:000252 BLOCK  /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23
c:0044 p:0074 s:0250 e:000249 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92
c:0043 p:0023 s:0238 e:000237 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22
c:0042 p:0052 s:0232 e:000231 METHOD /usr/local/bundle/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31
c:0041 p:0033 s:0225 e:000224 BLOCK  /usr/local/bundle/gems/bundler-2.2.7/lib/bundler/runtime.rb:66 [FINISH]

If I run the command:
docker-compose down && docker-compose up

I get the following message in loop. In the log files I have the same information.

fabmanager_1 | 2021-02-24 08:38:49,729 INFO success: worker entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
fabmanager_1 | 2021-02-24 08:38:49,730 INFO exited: app (terminated by SIGABRT (core dumped); not expected)
fabmanager_1 | 2021-02-24 08:38:50,351 INFO spawned: ‹ app › with pid 11
fabmanager_1 | 2021-02-24 08:38:50,511 INFO exited: worker (terminated by SIGABRT (core dumped); not expected)
fabmanager_1 | 2021-02-24 08:38:51,512 INFO success: app entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
fabmanager_1 | 2021-02-24 08:38:51,513 INFO spawned: ‹ worker › with pid 12
fabmanager_1 | 2021-02-24 08:38:52,404 INFO exited: app (terminated by SIGABRT (core dumped); not expected)

Could you help me? Thank you in advanced!

Hi ! I’ve the same problem with the original production installation on Ubuntu Server 18.04 :

/usr/local/bundle/gems/ffi-1.12.2/lib/ffi/library.rb:112: [BUG] Illegal instruction at 0x00007f4a184bf904 ruby 2.6.6p146 (2020-03-31 revision 67876) [x86_64-linux-musl] ...

Seems to be a Ruby bug (?)

Working on a fix by rebuilding the sleede/fab-manager docker image with another version of the 2.6.6-alpine image version of Ruby (replacing 2.6.6-alpine by 2.6.7-alpine)

UPDATE : Seems to work, I’ve successfully installed Fab-manager with the modified image (with some errors and I’ve also had to edit the initial install script) but it works !

If you want @Sylvain, we can share about this solution (I also speak French btw)

Hi @binForYou,
I updated ffi in v4.7.0 guessing that fixes the issue but if you experienced the issue with a later version, I’ll be pleased to integrate your fix in Fab-manager.

You can do it by forking the project then opening a pull request on GitHub.

1 « J'aime »

Hello @binForYou it seems I’m running into the same issue you have been. Except that Ruby 2.6.7 is already in place, but I have the same instruction error during the installation script :
/usr/local/bundle/gems/ffi-1.15.1/lib/ffi/library.rb:112: [BUG] Illegal instruction at 0x00007f68eb1f4904ruby 2.6.7p197 (2021-04-05 revision 67941) [x86_64-linux-musl]

I’m on a brain new fresh install and stay stuck on this issue…

According to this thead, the issue may be related to some CPU architecture details, especially when using VM. There’s a chance that a further version of sassc fixes the issues. I’ll try to update it in the upcoming version and keep you updated.

@TooT @binForYou The issue has been addressed in Fab-manager v5.1.10. You can proceed with the upgrade to solve it.

Thanks a lot @Sylvain ! I keep you updated about this issue.